Geofencing Blog For App Developers

Upgrading the Plot Plugin for IOS8

As we probably all have seen during the latest keynote from Apple, there will be a new release of IOS at September 19. In IOS 8 some breaking changes are made to the location services and the usage of local notifications. Therefore it is required that you upgrade your version of the Plot plugin to 1.6.2 on IOS. You can download the latest version from our dashboard. When you don’t update Plot to the latest version, Plot won’t work correctly on new installs of your app. Users then won’t receive location based notifications. When your users upgrade their phone from IOS 7 to IOS 8, then old versions of the Plot plugin will continue to work correctly in already installed apps.

It is now mandatory to specify in your Info.plist why your app requires the use of the location services. This message is shown when permission for location services is requested and after a couple of days to verify that the user wants to continue to allow the location services in the background.

Allow the plugin to access your location even when you are not using the app?

Local notifications now also require an opt-in by the user. When this permission isn’t asked no notifications can be sent to the user. The Plot plugin will now ask this permission once it is enabled.

The Plot Plugin would like to send you notifications

When you are already on Plot version 1.5 or newer, upgrading is trivial. It is required to use the SDK of the new XCode 6 to compile and link the code. You can download the latest version from our dashboard. Replace libPlot-….a with the latest version. Then you have to add an entry to your Info.Plist with the key NSLocationAlwaysUsageDescription. The value must be a message that describes why your app uses the location of the device. For example: “Your location is used to instantly inform you when you are near a location that is interesting to you.” If you are using version 1.4 or earlier of the Plot plugin then look at Migrating from previous versions in our documentation.

Adding a property to the .plist file
Setting the property value in the .plist file

Our library is still compatible with IOS 6 (binary compatible with IOS 4.3 and up). The Android version of Plot has remained unchanged.

plugin Developer plot ios

Subscribe to Email Updates